René's URL Explorer Experiment


Title: RFC 6570: URI Template | RFC Editor

Open Graph Title: RFC 6570: URI Template | RFC Editor

Description: A URI Template is a compact sequence of characters for describing a range of Uniform Resource Identifiers through variable expansion. This specification defines the URI Template syntax and the process for expanding a URI Template into a URI reference, along with guidelines for the use of URI Templates on the Internet. [STANDARDS-TRACK]

Open Graph Description: A URI Template is a compact sequence of characters for describing a range of Uniform Resource Identifiers through variable expansion. This specification defines the URI Template syntax and the process for expanding a URI Template into a URI reference, along with guidelines for the use of URI Templates on the Internet. [STANDARDS-TRACK]

Keywords:

Opengraph URL: https://www.rfc-editor.org/info/rfc6570/

Generator: Nuxt

direct link

Domain: tools.ietf.org

og:imagehttps://www.rfc-editor.org/api/v1/meta-thumbnail/rfc6570.png
og:image:altRFC 6570: URI Template. A URI Template is a compact sequence of characters for describing a range of Uniform Resource Identifiers through variable expansion. This specification defines the URI Template syntax and the process for expanding a URI Template into a URI reference, along with guidelines for the use of URI Templates on the Internet. [STANDARDS-TRACK].
og:image:typeimage/png
og:image:width1200
og:image:height630
og:typearticle
article:modified_time2012-03-28
resource-timestamp:info-rfc65702026-11-02T21:22:46.299+00:00
citation_authorD. Orchard
citation_doi10.17487/RFC6570
citation_publication_date2012/03/28
citation_technical_report_numberRFC 6570
citation_technical_report_institutionRFC Editor
citation_titleURI Template

Links:

Skip to content https://tools.ietf.org/html/rfc6570#main
https://tools.ietf.org/
https://tools.ietf.org/search/
What is an RFC?https://tools.ietf.org/series/rfc/
How can I use RFCs?https://tools.ietf.org/series/rfc-use/
Browse all RFCshttps://tools.ietf.org/rfc-index/
RFCs by Subjecthttps://tools.ietf.org/subjects/
Download RFCshttps://tools.ietf.org/series/rfc-download/
Errata in RFCshttps://tools.ietf.org/series/rfc-errata/
FAQhttps://tools.ietf.org/series/rfc-faq/
How RFCs are createdhttps://tools.ietf.org/authors/rfc-how-to/
Independent Submissionshttps://tools.ietf.org/authors/rfc-independent-submissions/
Style Guidehttps://tools.ietf.org/authors/rfc-style-guide/
RFC Publication Processhttps://authors.ietf.org/rfc-publication-process
Document Queuehttps://queue.rfc-editor.org
About RFC Editorhttps://tools.ietf.org/about/rfc-editor/
Reportshttps://tools.ietf.org/about/rpc-reports/
Privacy Statementhttps://www.ietf.org/privacy-statement/
Contacthttps://tools.ietf.org/about/contact/
https://tools.ietf.org/search/
What is an RFC?https://tools.ietf.org/series/rfc/
How can I use RFCs?https://tools.ietf.org/series/rfc-use/
Browse all RFCshttps://tools.ietf.org/rfc-index/
RFCs by Subjecthttps://tools.ietf.org/subjects/
Download RFCshttps://tools.ietf.org/series/rfc-download/
Errata in RFCshttps://tools.ietf.org/series/rfc-errata/
FAQhttps://tools.ietf.org/series/rfc-faq/
How RFCs are createdhttps://tools.ietf.org/authors/rfc-how-to/
Independent Submissionshttps://tools.ietf.org/authors/rfc-independent-submissions/
Style Guidehttps://tools.ietf.org/authors/rfc-style-guide/
RFC Publication Processhttps://authors.ietf.org/rfc-publication-process
Document Queuehttps://queue.rfc-editor.org
About RFC Editorhttps://tools.ietf.org/about/rfc-editor/
Reportshttps://tools.ietf.org/about/rpc-reports/
Privacy Statementhttps://www.ietf.org/privacy-statement/
Contacthttps://tools.ietf.org/about/contact/
Searchhttps://tools.ietf.org/search/
Homehttps://tools.ietf.org/
Plain Texthttps://tools.ietf.org/rfc/rfc6570.txt
Compact HTMLhttps://tools.ietf.org/rfc/rfc6570.html
internationalizationhttps://tools.ietf.org/subjects/internationalization/
IRIhttps://tools.ietf.org/subjects/iri/
Section 2 of RFC 5741https://tools.ietf.org/info/rfc5741/#section-2
http://www.rfc-editor.org/info/rfc6570https://tools.ietf.org/info/rfc6570
BCP 78https://tools.ietf.org/bcp/bcp78
http://trustee.ietf.org/license-infohttp://trustee.ietf.org/license-info
RFC 6570https://tools.ietf.org/info/rfc6570/
1https://tools.ietf.org/html/rfc6570#section-1
3https://tools.ietf.org/html/rfc6570#page-3
1.1https://tools.ietf.org/html/rfc6570#section-1.1
3https://tools.ietf.org/html/rfc6570#page-3
1.2https://tools.ietf.org/html/rfc6570#section-1.2
5https://tools.ietf.org/html/rfc6570#page-5
1.3https://tools.ietf.org/html/rfc6570#section-1.3
9https://tools.ietf.org/html/rfc6570#page-9
1.4https://tools.ietf.org/html/rfc6570#section-1.4
10https://tools.ietf.org/html/rfc6570#page-10
1.5https://tools.ietf.org/html/rfc6570#section-1.5
11https://tools.ietf.org/html/rfc6570#page-11
1.6https://tools.ietf.org/html/rfc6570#section-1.6
12https://tools.ietf.org/html/rfc6570#page-12
2https://tools.ietf.org/html/rfc6570#section-2
13https://tools.ietf.org/html/rfc6570#page-13
2.1https://tools.ietf.org/html/rfc6570#section-2.1
13https://tools.ietf.org/html/rfc6570#page-13
2.2https://tools.ietf.org/html/rfc6570#section-2.2
13https://tools.ietf.org/html/rfc6570#page-13
2.3https://tools.ietf.org/html/rfc6570#section-2.3
14https://tools.ietf.org/html/rfc6570#page-14
2.4https://tools.ietf.org/html/rfc6570#section-2.4
15https://tools.ietf.org/html/rfc6570#page-15
2.4.1https://tools.ietf.org/html/rfc6570#section-2.4.1
15https://tools.ietf.org/html/rfc6570#page-15
2.4.2https://tools.ietf.org/html/rfc6570#section-2.4.2
16https://tools.ietf.org/html/rfc6570#page-16
3https://tools.ietf.org/html/rfc6570#section-3
18https://tools.ietf.org/html/rfc6570#page-18
3.1https://tools.ietf.org/html/rfc6570#section-3.1
18https://tools.ietf.org/html/rfc6570#page-18
3.2https://tools.ietf.org/html/rfc6570#section-3.2
18https://tools.ietf.org/html/rfc6570#page-18
3.2.1https://tools.ietf.org/html/rfc6570#section-3.2.1
19https://tools.ietf.org/html/rfc6570#page-19
3.2.2https://tools.ietf.org/html/rfc6570#section-3.2.2
21https://tools.ietf.org/html/rfc6570#page-21
3.2.3https://tools.ietf.org/html/rfc6570#section-3.2.3
22https://tools.ietf.org/html/rfc6570#page-22
3.2.4https://tools.ietf.org/html/rfc6570#section-3.2.4
23https://tools.ietf.org/html/rfc6570#page-23
3.2.5https://tools.ietf.org/html/rfc6570#section-3.2.5
24https://tools.ietf.org/html/rfc6570#page-24
3.2.6https://tools.ietf.org/html/rfc6570#section-3.2.6
24https://tools.ietf.org/html/rfc6570#page-24
3.2.7https://tools.ietf.org/html/rfc6570#section-3.2.7
25https://tools.ietf.org/html/rfc6570#page-25
3.2.8https://tools.ietf.org/html/rfc6570#section-3.2.8
26https://tools.ietf.org/html/rfc6570#page-26
3.2.9https://tools.ietf.org/html/rfc6570#section-3.2.9
27https://tools.ietf.org/html/rfc6570#page-27
4https://tools.ietf.org/html/rfc6570#section-4
27https://tools.ietf.org/html/rfc6570#page-27
5https://tools.ietf.org/html/rfc6570#section-5
28https://tools.ietf.org/html/rfc6570#page-28
6https://tools.ietf.org/html/rfc6570#section-6
28https://tools.ietf.org/html/rfc6570#page-28
6.1https://tools.ietf.org/html/rfc6570#section-6.1
28https://tools.ietf.org/html/rfc6570#page-28
6.2https://tools.ietf.org/html/rfc6570#section-6.2
29https://tools.ietf.org/html/rfc6570#page-29
Appendix Ahttps://tools.ietf.org/html/rfc6570#appendix-A
30https://tools.ietf.org/html/rfc6570#page-30
RFC 6570https://tools.ietf.org/info/rfc6570/
1https://tools.ietf.org/html/rfc6570#section-1
1.1https://tools.ietf.org/html/rfc6570#section-1.1
RFC3986https://tools.ietf.org/info/rfc3986/
Section 2https://tools.ietf.org/html/rfc6570#section-2
Section 3https://tools.ietf.org/html/rfc6570#section-3
RFC 6570https://tools.ietf.org/info/rfc6570/
RFC 6570https://tools.ietf.org/info/rfc6570/
RFC3987https://tools.ietf.org/info/rfc3987/
Section 3.2 of [RFC3987]https://tools.ietf.org/info/rfc3987/#section-3.2
1.2https://tools.ietf.org/html/rfc6570#section-1.2
Section 1.5https://tools.ietf.org/html/rfc6570#section-1.5
Section 1.5https://tools.ietf.org/html/rfc6570#section-1.5
RFC 6570https://tools.ietf.org/info/rfc6570/
RFC 6570https://tools.ietf.org/info/rfc6570/
Section 2.4.1https://tools.ietf.org/html/rfc6570#section-2.4.1
RFC 6570https://tools.ietf.org/info/rfc6570/
Section 2.4.2https://tools.ietf.org/html/rfc6570#section-2.4.2
RFC 6570https://tools.ietf.org/info/rfc6570/
1.3https://tools.ietf.org/html/rfc6570#section-1.3
WSDLhttps://tools.ietf.org/html/rfc6570#ref-WSDL
WADLhttps://tools.ietf.org/html/rfc6570#ref-WADL
OpenSearchhttps://tools.ietf.org/html/rfc6570#ref-OpenSearch
RFC 6570https://tools.ietf.org/info/rfc6570/
1.4https://tools.ietf.org/html/rfc6570#section-1.4
RFC 6570https://tools.ietf.org/info/rfc6570/
1.5https://tools.ietf.org/html/rfc6570#section-1.5
RFC2119https://tools.ietf.org/info/rfc2119/
RFC5234https://tools.ietf.org/info/rfc5234/
RFC5234https://tools.ietf.org/info/rfc5234/
RFC3986https://tools.ietf.org/info/rfc3986/
RFC3987https://tools.ietf.org/info/rfc3987/
RFC 6570https://tools.ietf.org/info/rfc6570/
1.6https://tools.ietf.org/html/rfc6570#section-1.6
RFC6365https://tools.ietf.org/info/rfc6365/
ASCIIhttps://tools.ietf.org/html/rfc6570#ref-ASCII
UNIV6https://tools.ietf.org/html/rfc6570#ref-UNIV6
UNIV6https://tools.ietf.org/html/rfc6570#ref-UNIV6
UTR15https://tools.ietf.org/html/rfc6570#ref-UTR15
RFC3629https://tools.ietf.org/info/rfc3629/
RFC 6570https://tools.ietf.org/info/rfc6570/
2https://tools.ietf.org/html/rfc6570#section-2
2.1https://tools.ietf.org/html/rfc6570#section-2.1
RFC3629https://tools.ietf.org/info/rfc3629/
2.2https://tools.ietf.org/html/rfc6570#section-2.2
RFC 6570https://tools.ietf.org/info/rfc6570/
Section 3https://tools.ietf.org/html/rfc6570#section-3
2.3https://tools.ietf.org/html/rfc6570#section-2.3
RFC 6570https://tools.ietf.org/info/rfc6570/
Section 3.2.1https://tools.ietf.org/html/rfc6570#section-3.2.1
Section 3.2.1https://tools.ietf.org/html/rfc6570#section-3.2.1
2.4https://tools.ietf.org/html/rfc6570#section-2.4
2.4.1https://tools.ietf.org/html/rfc6570#section-2.4.1
RFC 6570https://tools.ietf.org/info/rfc6570/
2.4.2https://tools.ietf.org/html/rfc6570#section-2.4.2
RFC 6570https://tools.ietf.org/info/rfc6570/
UPU-S42https://tools.ietf.org/html/rfc6570#ref-UPU-S42
RFC 6570https://tools.ietf.org/info/rfc6570/
3https://tools.ietf.org/html/rfc6570#section-3
Appendix Ahttps://tools.ietf.org/html/rfc6570#appendix-A
3.1https://tools.ietf.org/html/rfc6570#section-3.1
3.2https://tools.ietf.org/html/rfc6570#section-3.2
RFC 6570https://tools.ietf.org/info/rfc6570/
3.2.1https://tools.ietf.org/html/rfc6570#section-3.2.1
Section 2.3https://tools.ietf.org/html/rfc6570#section-2.3
Section 1.6https://tools.ietf.org/html/rfc6570#section-1.6
RFC 6570https://tools.ietf.org/info/rfc6570/
RFC3629https://tools.ietf.org/info/rfc3629/
RFC 6570https://tools.ietf.org/info/rfc6570/
3.2.2https://tools.ietf.org/html/rfc6570#section-3.2.2
Section 3.2.1https://tools.ietf.org/html/rfc6570#section-3.2.1
RFC 6570https://tools.ietf.org/info/rfc6570/
3.2.3https://tools.ietf.org/html/rfc6570#section-3.2.3
Section 3.2.1https://tools.ietf.org/html/rfc6570#section-3.2.1
RFC 6570https://tools.ietf.org/info/rfc6570/
3.2.4https://tools.ietf.org/html/rfc6570#section-3.2.4
RFC 6570https://tools.ietf.org/info/rfc6570/
3.2.5https://tools.ietf.org/html/rfc6570#section-3.2.5
Section 3.2.1https://tools.ietf.org/html/rfc6570#section-3.2.1
3.2.6https://tools.ietf.org/html/rfc6570#section-3.2.6
Section 3.2.1https://tools.ietf.org/html/rfc6570#section-3.2.1
RFC 6570https://tools.ietf.org/info/rfc6570/
3.2.7https://tools.ietf.org/html/rfc6570#section-3.2.7
Section 3.2.1https://tools.ietf.org/html/rfc6570#section-3.2.1
RFC 6570https://tools.ietf.org/info/rfc6570/
3.2.8https://tools.ietf.org/html/rfc6570#section-3.2.8
Section 3.2.1https://tools.ietf.org/html/rfc6570#section-3.2.1
RFC 6570https://tools.ietf.org/info/rfc6570/
3.2.9https://tools.ietf.org/html/rfc6570#section-3.2.9
Section 3.2.1https://tools.ietf.org/html/rfc6570#section-3.2.1
4https://tools.ietf.org/html/rfc6570#section-4
RFC 6570https://tools.ietf.org/info/rfc6570/
Section 7 of [RFC3986]https://tools.ietf.org/info/rfc3986/#section-7
5https://tools.ietf.org/html/rfc6570#section-5
6https://tools.ietf.org/html/rfc6570#section-6
6.1https://tools.ietf.org/html/rfc6570#section-6.1
BCP 14https://tools.ietf.org/bcp/bcp14
RFC 2119https://tools.ietf.org/info/rfc2119/
RFC 3629https://tools.ietf.org/info/rfc3629/
RFC 3986https://tools.ietf.org/info/rfc3986/
RFC 6570https://tools.ietf.org/info/rfc6570/
RFC 3987https://tools.ietf.org/info/rfc3987/
RFC 5234https://tools.ietf.org/info/rfc5234/
BCP 166https://tools.ietf.org/bcp/bcp166
RFC 6365https://tools.ietf.org/info/rfc6365/
http://www.unicode.org/versions/Unicode6.0.0/http://www.unicode.org/versions/Unicode6.0.0/
http://www.unicode.org/unicode/reports/tr15/http://www.unicode.org/unicode/reports/tr15/tr15-23.html
tr15-23.htmlhttp://www.unicode.org/unicode/reports/tr15/tr15-23.html
6.2https://tools.ietf.org/html/rfc6570#section-6.2
http://www.opensearch.org/Specifications/OpenSearchhttp://www.opensearch.org/Specifications/OpenSearch
http://www.upu.int/en/activities/addressing/http://www.upu.int/en/activities/addressing/standards.html
standards.htmlhttp://www.upu.int/en/activities/addressing/standards.html
http://www.w3.org/Submission/2009/http://www.w3.org/Submission/2009/SUBM-wadl-20090831/
SUBM-wadl-20090831/http://www.w3.org/Submission/2009/SUBM-wadl-20090831/
http://www.w3.org/TR/2007/http://www.w3.org/TR/2007/REC-wsdl20-20070626
REC-wsdl20-20070626http://www.w3.org/TR/2007/REC-wsdl20-20070626
RFC 6570https://tools.ietf.org/info/rfc6570/
Appendix Ahttps://tools.ietf.org/html/rfc6570#appendix-A
Section 3.1https://tools.ietf.org/html/rfc6570#section-3.1
Section 2.3https://tools.ietf.org/html/rfc6570#section-2.3
RFC 6570https://tools.ietf.org/info/rfc6570/
Section 2.3https://tools.ietf.org/html/rfc6570#section-2.3
RFC 6570https://tools.ietf.org/info/rfc6570/
RFC 6570https://tools.ietf.org/info/rfc6570/
RFC 6570https://tools.ietf.org/info/rfc6570/
http://bitworking.org/http://bitworking.org/
http://roy.gbiv.com/http://roy.gbiv.com/
http://mitre.org/http://mitre.org/
http://www.mnot.net/http://www.mnot.net/
http://www.pacificspirit.com/http://www.pacificspirit.com/
1. Introduction https://tools.ietf.org/html/rfc6570#section-1
1.1. Overview https://tools.ietf.org/html/rfc6570#section-1.1
1.2. Levels and Expression Types https://tools.ietf.org/html/rfc6570#section-1.2
1.3. Design Considerations https://tools.ietf.org/html/rfc6570#section-1.3
1.4. Limitations https://tools.ietf.org/html/rfc6570#section-1.4
1.5. Notational Conventions https://tools.ietf.org/html/rfc6570#section-1.5
1.6. Character Encoding and Unicode Normalization https://tools.ietf.org/html/rfc6570#section-1.6
2. Syntax https://tools.ietf.org/html/rfc6570#section-2
2.1. Literals https://tools.ietf.org/html/rfc6570#section-2.1
2.2. Expressions https://tools.ietf.org/html/rfc6570#section-2.2
2.3. Variables https://tools.ietf.org/html/rfc6570#section-2.3
2.4. Value Modifiers https://tools.ietf.org/html/rfc6570#section-2.4
2.4.1. Prefix Values https://tools.ietf.org/html/rfc6570#section-2.4.1
2.4.2. Composite Values https://tools.ietf.org/html/rfc6570#section-2.4.2
3. Expansion https://tools.ietf.org/html/rfc6570#section-3
3.1. Literal Expansion https://tools.ietf.org/html/rfc6570#section-3.1
3.2. Expression Expansion https://tools.ietf.org/html/rfc6570#section-3.2
3.2.1. Variable Expansion https://tools.ietf.org/html/rfc6570#section-3.2.1
3.2.2. Simple String Expansion: {var} https://tools.ietf.org/html/rfc6570#section-3.2.2
3.2.3. Reserved Expansion: {+var} https://tools.ietf.org/html/rfc6570#section-3.2.3
3.2.4. Fragment Expansion: {#var} https://tools.ietf.org/html/rfc6570#section-3.2.4
3.2.5. Label Expansion with Dot-Prefix: {.var} https://tools.ietf.org/html/rfc6570#section-3.2.5
3.2.6. Path Segment Expansion: {/var} https://tools.ietf.org/html/rfc6570#section-3.2.6
3.2.7. Path-Style Parameter Expansion: {;var} https://tools.ietf.org/html/rfc6570#section-3.2.7
3.2.8. Form-Style Query Expansion: {?var} https://tools.ietf.org/html/rfc6570#section-3.2.8
3.2.9. Form-Style Query Continuation: {&var} https://tools.ietf.org/html/rfc6570#section-3.2.9
4. Security Considerations https://tools.ietf.org/html/rfc6570#section-4
5. Acknowledgments https://tools.ietf.org/html/rfc6570#section-5
6. References https://tools.ietf.org/html/rfc6570#section-6
6.1. Normative References https://tools.ietf.org/html/rfc6570#section-6.1
6.2. Informative References https://tools.ietf.org/html/rfc6570#section-6.2
Appendix A. Implementation Hints https://tools.ietf.org/html/rfc6570#appendix-A
J. Gregoriohttps://datatracker.ietf.org/person/Joe%20Gregorio
R. Fieldinghttps://datatracker.ietf.org/person/Roy%20T.%20Fielding
M. Hadleyhttps://datatracker.ietf.org/person/Marc%20Hadley
M. Nottinghamhttps://datatracker.ietf.org/person/Mark%20Nottingham
D. Orchardhttps://datatracker.ietf.org/person/David%20Orchard
IETFhttps://www.ietf.org
https://doi.org/10.17487/RFC6570https://doi.org/10.17487/RFC6570
TXThttps://tools.ietf.org/rfc/rfc6570.txt
HTMLhttps://tools.ietf.org/rfc/rfc6570.html
TXThttps://tools.ietf.org/refs/ref6570.txt
XMLhttps://bib.ietf.org/public/rfc/bibxml/reference.RFC.6570.xml
BibTeXhttps://datatracker.ietf.org/doc/rfc6570/bibtex/
View history of RFC 6570https://datatracker.ietf.org/doc/rfc6570/
RFC 6570 Erratahttps://errata.rfc-editor.org/search/?rfc_number=6570
About working group Applications Areahttps://datatracker.ietf.org/wg/app/about/
Applications Area documentshttps://datatracker.ietf.org/wg/app
Meetings for Applications Areahttps://datatracker.ietf.org/wg/app/meetings/
Internet Engineering Task Force https://www.ietf.org
https://www.ietf.org
System Statushttps://status.ietf.org
Report a Bughttps://github.com/ietf-tools/red/issues
IETF.orghttps://www.ietf.org
IRTF.orghttps://www.irtf.org
IAB.orghttps://www.iab.org
Datatrackerhttps://datatracker.ietf.org
Author Resourceshttps://authors.ietf.org
RFC Editorhttps://tools.ietf.org/about/contact/
rfc-dist Info Pagehttps://mailman.rfc-editor.org/mailman/listinfo/rfc-dist
rfc-interest Info Pagehttps://mailman.rfc-editor.org/mailman/listinfo/rfc-interest
Expand sidebarhttps://tools.ietf.org/html/rfc6570#top

Viewport: width=device-width, initial-scale=1


URLs of crawlers that visited me.