Title: Build(deps): bump phpmailer/phpmailer from 6.0.7 to 6.1.6 by dependabot[bot] · Pull Request #1 · modulusphp/modulusphp.com · GitHub
Open Graph Title: Build(deps): bump phpmailer/phpmailer from 6.0.7 to 6.1.6 by dependabot[bot] · Pull Request #1 · modulusphp/modulusphp.com
X Title: Build(deps): bump phpmailer/phpmailer from 6.0.7 to 6.1.6 by dependabot[bot] · Pull Request #1 · modulusphp/modulusphp.com
Description: Bumps phpmailer/phpmailer from 6.0.7 to 6.1.6. Release notes Sourced from phpmailer/phpmailer's releases. PHPMailer 6.1.6 This is a security release, with some other minor changes. For full details, refer to the advisory. SECURITY Fix insufficient output escaping bug in file attachment names. CVE-2020-13625. Reported by Elar Lang of Clarified Security. Correct Armenian ISO language code from am to hy, add mapping for fallback Use correct timeout property in debug output PHPMailer 6.1.5 This is a maintenance release. Reject invalid custom headers that are empty or contain breaks Various fixes for DKIM issues, especially when using mail() transport Drop the l= length tag from DKIM signatures; it's a mild security risk Ensure CRLF is used explicitly when needed, rather than static::$LE Add a method for trimming header content consistently Some minor tweaks to resolve static analyser complaints Check that attachment files are readable both when adding and when sending Work around Outlook bug in mishandling MIME preamble Danish translation improvements PHPMailer 6.1.4 The RFC2047 folding added in 6.1.0 was a little overenthusiastic; It will now only happen when header lines exceed 998 chars. Clean up hostname handling Avoid IDN error on older PHP versions, prep for PHP 8.0 Don't force RFC2047 folding unnecessarily Enable tests on full release of PHP 7.4 PHPMailer 6.1.3 Fix an issue preventing injected debug handlers from working Fix an issue relating to connection timeout Add SMTP::MAX_REPLY_LENGTH constant Remove some dev dependencies; phpdoc no longer included Fix an issue where non-compliant servers returning bare codes caused an SMTP hang PHPMailer 6.1.2 Substantial revision of DKIM header generation Use shorter hashes for auto-generated CID values Fix format of content-id headers, and only use them for inline attachments Remove all use of XHTML Lots of coding standards cleanup API docs are now auto-updated via GitHub actions Fix header separation bug created in 6.1.1 Fix misidentification of background attributes in SVG images in msgHTML PHPMailer 6.1.1 No code changes, just retagging for a misordered commit for 6.1.0. PHPMailer 6.1.0 ... (truncated) Changelog Sourced from phpmailer/phpmailer's changelog. Version 6.1.6 (May 27th, 2020) SECURITY Fix insufficient output escaping bug in file attachment names. CVE-2020-13625. Reported by Elar Lang of Clarified Security. Correct Armenian ISO language code from am to hy, add mapping for fallback Use correct timeout property in debug output Version 6.1.5 (March 14th, 2020) Reject invalid custom headers that are empty or contain breaks Various fixes for DKIM issues, especially when using mail() transport Drop the l= length tag from DKIM signatures; it's a mild security risk Ensure CRLF is used explicitly when needed, rather than static::$LE Add a method for trimming header content consistently Some minor tweaks to resolve static analyser complaints Check that attachment files are readable both when adding and when sending Work around Outlook bug in mishandling MIME preamble Danish translation improvements Version 6.1.4 (December 10th, 2019) Clean up hostname handling Avoid IDN error on older PHP versions, prep for PHP 8.0 Don't force RFC2047 folding unnecessarily Enable tests on full release of PHP 7.4 Version 6.1.3 (November 21st, 2019) Fix an issue preventing injected debug handlers from working Fix an issue relating to connection timeout Add SMTP::MAX_REPLY_LENGTH constant Remove some dev dependencies; phpdoc no longer included Fix an issue where non-compliant servers returning bare codes caused an SMTP hang Version 6.1.2 (November 13th, 2019) Substantial revision of DKIM header generation Use shorter hashes for auto-generated CID values Fix format of content-id headers, and only use them for inline attachments Remove all use of XHTML Lots of coding standards cleanup API docs are now auto-updated via GitHub actions Fix header separation bug created in 6.1.1 Fix misidentification of background attributes in SVG images in msgHTML Version 6.1.1 (September 27th 2019) Fix misordered version tag Version 6.1.0 (September 27th 2019) Multiple bug fixes for folding of long header lines, thanks to @caugner Add support for RFC2387 child element content-type hint in multipart/related structures. Support for Ical event methods other than REQUEST, thanks to @puhr-mde Change header folding and param separation to use spaces instead of tabs Use ; to separate multiple MIME header params Add support for RFC3461 DSN messages IMAP example code fixed ... (truncated) Commits c2796cb Merge pull request from GHSA-f7hx-fqxw-rvvj a7f1b23 Add funding info 5b63b39 Fix typos (#2037) c1c38e3 Correct Armenian language code a12c95e Use correct timeout property in debug output, clarify debug output, see #2018 a8bf068 6.1.5 2e72725 Rewrite and extension of translation (#1989) 55e0b34 Fix issue #2008 - MS Outlook corrupts formatting multipart EML files (#2009) a55152f Typo fix for #2007 e9710ee Update README.md (#2004) Additional commits viewable in compare view Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase. Dependabot commands and options You can trigger Dependabot actions by commenting on this PR: @dependabot rebase will rebase this PR @dependabot recreate will recreate this PR, overwriting any edits that have been made to it @dependabot merge will merge this PR after your CI passes on it @dependabot squash and merge will squash and merge this PR after your CI passes on it @dependabot cancel merge will cancel a previously requested merge and block automerging @dependabot reopen will reopen this PR if it is closed @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself) @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself) @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself) @dependabot use these labels will set the current labels as the default for future PRs for this repo and language @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language You can disable automated security fix PRs for this repo from the Security Alerts page.
Open Graph Description: Bumps phpmailer/phpmailer from 6.0.7 to 6.1.6. Release notes Sourced from phpmailer/phpmailer's releases. PHPMailer 6.1.6 This is a security release, with some other minor changes. For full d...
X Description: Bumps phpmailer/phpmailer from 6.0.7 to 6.1.6. Release notes Sourced from phpmailer/phpmailer's releases. PHPMailer 6.1.6 This is a security release, with some other minor changes. For fu...
Opengraph URL: https://github.com/modulusphp/modulusphp.com/pull/1
X: @github
Domain: github.com
| react-profiling | 0 |
| react-import-map | react,react-dom,react-dom/client,react-dom/profiling,react-is,react-reconciler,react/compiler-runtime,react/jsx-dev-runtime,react/jsx-runtime,scheduler@d5750093facf |
| route-pattern | /:user_id/:repository/pull/:id/files(.:format) |
| route-controller | pull_requests |
| route-action | files |
| fetch-nonce | v2:86580be7-2b78-5c34-0fab-4e21d31704d5 |
| current-catalog-service-hash | ae870bc5e265a340912cde392f23dad3671a0a881730ffdadd82f2f57d81641b |
| request-id | A206:D5CEE:9AB704:CCC956:6AF84F77 |
| html-safe-nonce | e886e368bd8df593873c84d38f4708882ba8d65500b141a425b384ad1bc509bf |
| visitor-payload | eyJyZWZlcnJlciI6IiIsInJlcXVlc3RfaWQiOiJBMjA2OkQ1Q0VFOjlBQjcwNDpDQ0M5NTY6NkFGODRGNzciLCJ2aXNpdG9yX2lkIjoiNzQ0Mjg5OTUzNTE0MDUwNzUxMiIsInJlZ2lvbl9lZGdlIjoiaWFkIiwicmVnaW9uX3JlbmRlciI6ImlhZCJ9 |
| visitor-hmac | 09285b377549bbf1208b857d3f0ce66b7102ca24d6ee1c62f9979913a7e152e2 |
| hovercard-subject-tag | pull_request:424002436 |
| github-keyboard-shortcuts | repository,pull-request-list,pull-request-conversation,pull-request-files-changed,copilot |
| google-site-verification | Apib7-x98H0j5cPqHWwSMm6dNU4GmODRoqxLiDzdx9I |
| octolytics-url | https://collector.github.com/github/collect |
| analytics-location | / |
| fb:app_id | 1401488693436528 |
| apple-itunes-app | app-id=1477376905, app-argument=https://github.com/modulusphp/modulusphp.com/pull/1/files |
| twitter:image | https://avatars.githubusercontent.com/in/29110?s=400&v=4 |
| twitter:card | summary_large_image |
| og:image | https://avatars.githubusercontent.com/in/29110?s=400&v=4 |
| og:image:alt | Bumps phpmailer/phpmailer from 6.0.7 to 6.1.6. Release notes Sourced from phpmailer/phpmailer's releases. PHPMailer 6.1.6 This is a security release, with some other minor changes. For full d... |
| og:site_name | GitHub |
| og:type | object |
| hostname | github.com |
| expected-hostname | github.com |
| None | 5713ecd83001b2f55c3509fb7a292bf7d66d0f167c7ae87a9f7eaec5a52bf8db |
| turbo-cache-control | no-preview |
| diff-view | unified |
| go-import | github.com/modulusphp/modulusphp.com git https://github.com/modulusphp/modulusphp.com.git |
| octolytics-dimension-user_id | 39043921 |
| octolytics-dimension-user_login | modulusphp |
| octolytics-dimension-repository_id | 170936595 |
| octolytics-dimension-repository_nwo | modulusphp/modulusphp.com |
| octolytics-dimension-repository_public | true |
| octolytics-dimension-repository_is_fork | false |
| octolytics-dimension-repository_network_root_id | 170936595 |
| octolytics-dimension-repository_network_root_nwo | modulusphp/modulusphp.com |
| turbo-body-classes | logged-out env-production page-responsive |
| disable-turbo | true |
| browser-stats-url | https://api.github.com/_private/browser/stats |
| browser-errors-url | https://api.github.com/_private/browser/errors |
| release | 653be32ff5c755082a4db662491bfbbcfc9112c1 |
| ui-target | full |
| theme-color | #1e2327 |
| color-scheme | light dark |
Links:
Viewport: width=device-width