René's URL Explorer Experiment


Title: RFC 6570 - URI Template

Open Graph Title: RFC 6570: URI Template

Description: URI Template (RFC 6570, )

Open Graph Description: A URI Template is a compact sequence of characters for describing a range of Uniform Resource Identifiers through variable expansion. This specification defines the URI Template syntax and the process for expanding a URI Template into a URI reference, along with guidelines for the use of URI Templates on the Internet. [STANDARDS-TRACK]

Mail addresses
joe@bitworking.org
fielding@gbiv.com
Marc.Hadley@oracle.com
mnot@mnot.net
orchard@pacificspirit.com
rfc6570@ietf.org?subject=rfc6570
joe@bitworking.org
fielding@gbiv.com
Marc.Hadley@oracle.com
mnot@mnot.net
orchard@pacificspirit.com
rfc6570@ietf.org?subject=rfc6570

Opengraph URL: https://datatracker.ietf.org/doc/html/rfc6570

direct link

Domain: datatracker.ietf.org

NoneIE=edge
msapplication-TileColor#ffffff
theme-color#ffffff
og:site_nameIETF Datatracker
og:typearticle
og:imagehttps://static.ietf.org/dt/12.83.0/ietf/images/ietf-logo-card.png
og:image:altLogo of the IETF
article:sectionIETF - Internet Engineering Task Force
og:image:typeimage/png
og:image:width1200
og:image:height630
twitter:cardsummary_large_image
article:authorDavid Orchard

Links:

RFC 6570 Proposed Standard https://datatracker.ietf.org/doc/rfc6570/
View errata https://www.rfc-editor.org/errata_search.php?rfc=6570
Report errata https://www.rfc-editor.org/errata.php#reportnew
draft-gregorio-uritemplatehttps://datatracker.ietf.org/doc/draft-gregorio-uritemplate/08/
08 https://datatracker.ietf.org/doc/html/draft-gregorio-uritemplate-08
RFC 6570 https://datatracker.ietf.org/doc/html/rfc6570
J. Gregoriohttps://datatracker.ietf.org/person/joe@bitworking.org
R. Fieldinghttps://datatracker.ietf.org/person/fielding@gbiv.com
M. Hadleyhttps://datatracker.ietf.org/person/Marc.Hadley@oracle.com
M. Nottinghamhttps://datatracker.ietf.org/person/mnot@mnot.net
D. Orchardhttps://datatracker.ietf.org/person/orchard@pacificspirit.com
txt https://www.rfc-editor.org/rfc/rfc6570.txt
html https://www.rfc-editor.org/rfc/rfc6570.html
w/errata https://www.rfc-editor.org/rfc/inline-errata/rfc6570.html
bibtex https://datatracker.ietf.org/doc/rfc6570/bibtex/
Report a bug https://github.com/ietf-tools/datatracker/issues/new/choose
Section 2 of RFC 5741https://datatracker.ietf.org/doc/html/rfc5741#section-2
http://www.rfc-editor.org/info/rfc6570http://www.rfc-editor.org/info/rfc6570
BCP 78https://datatracker.ietf.org/doc/html/bcp78
http://trustee.ietf.org/license-infohttp://trustee.ietf.org/license-info
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
1https://datatracker.ietf.org/doc/html/rfc6570#section-1
3https://datatracker.ietf.org/doc/html/rfc6570#page-3
1.1https://datatracker.ietf.org/doc/html/rfc6570#section-1.1
3https://datatracker.ietf.org/doc/html/rfc6570#page-3
1.2https://datatracker.ietf.org/doc/html/rfc6570#section-1.2
5https://datatracker.ietf.org/doc/html/rfc6570#page-5
1.3https://datatracker.ietf.org/doc/html/rfc6570#section-1.3
9https://datatracker.ietf.org/doc/html/rfc6570#page-9
1.4https://datatracker.ietf.org/doc/html/rfc6570#section-1.4
10https://datatracker.ietf.org/doc/html/rfc6570#page-10
1.5https://datatracker.ietf.org/doc/html/rfc6570#section-1.5
11https://datatracker.ietf.org/doc/html/rfc6570#page-11
1.6https://datatracker.ietf.org/doc/html/rfc6570#section-1.6
12https://datatracker.ietf.org/doc/html/rfc6570#page-12
2https://datatracker.ietf.org/doc/html/rfc6570#section-2
13https://datatracker.ietf.org/doc/html/rfc6570#page-13
2.1https://datatracker.ietf.org/doc/html/rfc6570#section-2.1
13https://datatracker.ietf.org/doc/html/rfc6570#page-13
2.2https://datatracker.ietf.org/doc/html/rfc6570#section-2.2
13https://datatracker.ietf.org/doc/html/rfc6570#page-13
2.3https://datatracker.ietf.org/doc/html/rfc6570#section-2.3
14https://datatracker.ietf.org/doc/html/rfc6570#page-14
2.4https://datatracker.ietf.org/doc/html/rfc6570#section-2.4
15https://datatracker.ietf.org/doc/html/rfc6570#page-15
2.4.1https://datatracker.ietf.org/doc/html/rfc6570#section-2.4.1
15https://datatracker.ietf.org/doc/html/rfc6570#page-15
2.4.2https://datatracker.ietf.org/doc/html/rfc6570#section-2.4.2
16https://datatracker.ietf.org/doc/html/rfc6570#page-16
3https://datatracker.ietf.org/doc/html/rfc6570#section-3
18https://datatracker.ietf.org/doc/html/rfc6570#page-18
3.1https://datatracker.ietf.org/doc/html/rfc6570#section-3.1
18https://datatracker.ietf.org/doc/html/rfc6570#page-18
3.2https://datatracker.ietf.org/doc/html/rfc6570#section-3.2
18https://datatracker.ietf.org/doc/html/rfc6570#page-18
3.2.1https://datatracker.ietf.org/doc/html/rfc6570#section-3.2.1
19https://datatracker.ietf.org/doc/html/rfc6570#page-19
3.2.2https://datatracker.ietf.org/doc/html/rfc6570#section-3.2.2
21https://datatracker.ietf.org/doc/html/rfc6570#page-21
3.2.3https://datatracker.ietf.org/doc/html/rfc6570#section-3.2.3
22https://datatracker.ietf.org/doc/html/rfc6570#page-22
3.2.4https://datatracker.ietf.org/doc/html/rfc6570#section-3.2.4
23https://datatracker.ietf.org/doc/html/rfc6570#page-23
3.2.5https://datatracker.ietf.org/doc/html/rfc6570#section-3.2.5
24https://datatracker.ietf.org/doc/html/rfc6570#page-24
3.2.6https://datatracker.ietf.org/doc/html/rfc6570#section-3.2.6
24https://datatracker.ietf.org/doc/html/rfc6570#page-24
3.2.7https://datatracker.ietf.org/doc/html/rfc6570#section-3.2.7
25https://datatracker.ietf.org/doc/html/rfc6570#page-25
3.2.8https://datatracker.ietf.org/doc/html/rfc6570#section-3.2.8
26https://datatracker.ietf.org/doc/html/rfc6570#page-26
3.2.9https://datatracker.ietf.org/doc/html/rfc6570#section-3.2.9
27https://datatracker.ietf.org/doc/html/rfc6570#page-27
4https://datatracker.ietf.org/doc/html/rfc6570#section-4
27https://datatracker.ietf.org/doc/html/rfc6570#page-27
5https://datatracker.ietf.org/doc/html/rfc6570#section-5
28https://datatracker.ietf.org/doc/html/rfc6570#page-28
6https://datatracker.ietf.org/doc/html/rfc6570#section-6
28https://datatracker.ietf.org/doc/html/rfc6570#page-28
6.1https://datatracker.ietf.org/doc/html/rfc6570#section-6.1
28https://datatracker.ietf.org/doc/html/rfc6570#page-28
6.2https://datatracker.ietf.org/doc/html/rfc6570#section-6.2
29https://datatracker.ietf.org/doc/html/rfc6570#page-29
Appendix Ahttps://datatracker.ietf.org/doc/html/rfc6570#appendix-A
30https://datatracker.ietf.org/doc/html/rfc6570#page-30
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
1https://datatracker.ietf.org/doc/html/rfc6570#section-1
1.1https://datatracker.ietf.org/doc/html/rfc6570#section-1.1
RFC3986https://datatracker.ietf.org/doc/html/rfc3986
Section 2https://datatracker.ietf.org/doc/html/rfc6570#section-2
Section 3https://datatracker.ietf.org/doc/html/rfc6570#section-3
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
RFC3987https://datatracker.ietf.org/doc/html/rfc3987
Section 3.2 of [RFC3987]https://datatracker.ietf.org/doc/html/rfc3987#section-3.2
1.2https://datatracker.ietf.org/doc/html/rfc6570#section-1.2
Section 1.5https://datatracker.ietf.org/doc/html/rfc6570#section-1.5
Section 1.5https://datatracker.ietf.org/doc/html/rfc6570#section-1.5
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
Section 2.4.1https://datatracker.ietf.org/doc/html/rfc6570#section-2.4.1
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
Section 2.4.2https://datatracker.ietf.org/doc/html/rfc6570#section-2.4.2
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
1.3https://datatracker.ietf.org/doc/html/rfc6570#section-1.3
WSDLhttps://datatracker.ietf.org/doc/html/rfc6570#ref-WSDL
WADLhttps://datatracker.ietf.org/doc/html/rfc6570#ref-WADL
OpenSearchhttps://datatracker.ietf.org/doc/html/rfc6570#ref-OpenSearch
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
1.4https://datatracker.ietf.org/doc/html/rfc6570#section-1.4
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
1.5https://datatracker.ietf.org/doc/html/rfc6570#section-1.5
RFC2119https://datatracker.ietf.org/doc/html/rfc2119
RFC5234https://datatracker.ietf.org/doc/html/rfc5234
RFC5234https://datatracker.ietf.org/doc/html/rfc5234
RFC3986https://datatracker.ietf.org/doc/html/rfc3986
RFC3987https://datatracker.ietf.org/doc/html/rfc3987
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
1.6https://datatracker.ietf.org/doc/html/rfc6570#section-1.6
RFC6365https://datatracker.ietf.org/doc/html/rfc6365
ASCIIhttps://datatracker.ietf.org/doc/html/rfc6570#ref-ASCII
UNIV6https://datatracker.ietf.org/doc/html/rfc6570#ref-UNIV6
UNIV6https://datatracker.ietf.org/doc/html/rfc6570#ref-UNIV6
UTR15https://datatracker.ietf.org/doc/html/rfc6570#ref-UTR15
RFC3629https://datatracker.ietf.org/doc/html/rfc3629
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
2https://datatracker.ietf.org/doc/html/rfc6570#section-2
2.1https://datatracker.ietf.org/doc/html/rfc6570#section-2.1
RFC3629https://datatracker.ietf.org/doc/html/rfc3629
2.2https://datatracker.ietf.org/doc/html/rfc6570#section-2.2
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
Section 3https://datatracker.ietf.org/doc/html/rfc6570#section-3
2.3https://datatracker.ietf.org/doc/html/rfc6570#section-2.3
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
Section 3.2.1https://datatracker.ietf.org/doc/html/rfc6570#section-3.2.1
Section 3.2.1https://datatracker.ietf.org/doc/html/rfc6570#section-3.2.1
2.4https://datatracker.ietf.org/doc/html/rfc6570#section-2.4
2.4.1https://datatracker.ietf.org/doc/html/rfc6570#section-2.4.1
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
2.4.2https://datatracker.ietf.org/doc/html/rfc6570#section-2.4.2
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
UPU-S42https://datatracker.ietf.org/doc/html/rfc6570#ref-UPU-S42
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
3https://datatracker.ietf.org/doc/html/rfc6570#section-3
Appendix Ahttps://datatracker.ietf.org/doc/html/rfc6570#appendix-A
3.1https://datatracker.ietf.org/doc/html/rfc6570#section-3.1
3.2https://datatracker.ietf.org/doc/html/rfc6570#section-3.2
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
3.2.1https://datatracker.ietf.org/doc/html/rfc6570#section-3.2.1
Section 2.3https://datatracker.ietf.org/doc/html/rfc6570#section-2.3
Section 1.6https://datatracker.ietf.org/doc/html/rfc6570#section-1.6
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
RFC3629https://datatracker.ietf.org/doc/html/rfc3629
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
3.2.2https://datatracker.ietf.org/doc/html/rfc6570#section-3.2.2
Section 3.2.1https://datatracker.ietf.org/doc/html/rfc6570#section-3.2.1
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
3.2.3https://datatracker.ietf.org/doc/html/rfc6570#section-3.2.3
Section 3.2.1https://datatracker.ietf.org/doc/html/rfc6570#section-3.2.1
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
3.2.4https://datatracker.ietf.org/doc/html/rfc6570#section-3.2.4
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
3.2.5https://datatracker.ietf.org/doc/html/rfc6570#section-3.2.5
Section 3.2.1https://datatracker.ietf.org/doc/html/rfc6570#section-3.2.1
3.2.6https://datatracker.ietf.org/doc/html/rfc6570#section-3.2.6
Section 3.2.1https://datatracker.ietf.org/doc/html/rfc6570#section-3.2.1
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
3.2.7https://datatracker.ietf.org/doc/html/rfc6570#section-3.2.7
Section 3.2.1https://datatracker.ietf.org/doc/html/rfc6570#section-3.2.1
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
3.2.8https://datatracker.ietf.org/doc/html/rfc6570#section-3.2.8
Section 3.2.1https://datatracker.ietf.org/doc/html/rfc6570#section-3.2.1
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
3.2.9https://datatracker.ietf.org/doc/html/rfc6570#section-3.2.9
Section 3.2.1https://datatracker.ietf.org/doc/html/rfc6570#section-3.2.1
4https://datatracker.ietf.org/doc/html/rfc6570#section-4
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
Section 7 of [RFC3986]https://datatracker.ietf.org/doc/html/rfc3986#section-7
5https://datatracker.ietf.org/doc/html/rfc6570#section-5
6https://datatracker.ietf.org/doc/html/rfc6570#section-6
6.1https://datatracker.ietf.org/doc/html/rfc6570#section-6.1
BCP 14https://datatracker.ietf.org/doc/html/bcp14
RFC 2119https://datatracker.ietf.org/doc/html/rfc2119
RFC 3629https://datatracker.ietf.org/doc/html/rfc3629
RFC 3986https://datatracker.ietf.org/doc/html/rfc3986
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
RFC 3987https://datatracker.ietf.org/doc/html/rfc3987
RFC 5234https://datatracker.ietf.org/doc/html/rfc5234
BCP 166https://datatracker.ietf.org/doc/html/bcp166
RFC 6365https://datatracker.ietf.org/doc/html/rfc6365
http://www.unicode.org/versions/Unicode6.0.0/http://www.unicode.org/versions/Unicode6.0.0/
http://www.unicode.org/unicode/reports/tr15/http://www.unicode.org/unicode/reports/tr15/tr15-23.html
tr15-23.htmlhttp://www.unicode.org/unicode/reports/tr15/tr15-23.html
6.2https://datatracker.ietf.org/doc/html/rfc6570#section-6.2
http://www.opensearch.org/Specifications/OpenSearchhttp://www.opensearch.org/Specifications/OpenSearch
http://www.upu.int/en/activities/addressing/http://www.upu.int/en/activities/addressing/standards.html
standards.htmlhttp://www.upu.int/en/activities/addressing/standards.html
http://www.w3.org/Submission/2009/http://www.w3.org/Submission/2009/SUBM-wadl-20090831/
SUBM-wadl-20090831/http://www.w3.org/Submission/2009/SUBM-wadl-20090831/
http://www.w3.org/TR/2007/http://www.w3.org/TR/2007/REC-wsdl20-20070626
REC-wsdl20-20070626http://www.w3.org/TR/2007/REC-wsdl20-20070626
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
Appendix Ahttps://datatracker.ietf.org/doc/html/rfc6570#appendix-A
Section 3.1https://datatracker.ietf.org/doc/html/rfc6570#section-3.1
Section 2.3https://datatracker.ietf.org/doc/html/rfc6570#section-2.3
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
Section 2.3https://datatracker.ietf.org/doc/html/rfc6570#section-2.3
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
RFC 6570https://datatracker.ietf.org/doc/html/rfc6570
http://bitworking.org/http://bitworking.org/
http://roy.gbiv.com/http://roy.gbiv.com/
http://mitre.org/http://mitre.org/
http://www.mnot.net/http://www.mnot.net/
http://www.pacificspirit.com/http://www.pacificspirit.com/
Datatrackerhttps://datatracker.ietf.org/doc/rfc6570/
View errata https://www.rfc-editor.org/errata_search.php?rfc=6570
Report errata https://www.rfc-editor.org/errata.php#reportnew
draft-gregorio-uritemplatehttps://datatracker.ietf.org/doc/draft-gregorio-uritemplate/08/
08 https://datatracker.ietf.org/doc/html/draft-gregorio-uritemplate-08
RFC 6570 https://datatracker.ietf.org/doc/html/rfc6570
J. Gregoriohttps://datatracker.ietf.org/person/joe@bitworking.org
R. Fieldinghttps://datatracker.ietf.org/person/fielding@gbiv.com
M. Hadleyhttps://datatracker.ietf.org/person/Marc.Hadley@oracle.com
M. Nottinghamhttps://datatracker.ietf.org/person/mnot@mnot.net
D. Orchardhttps://datatracker.ietf.org/person/orchard@pacificspirit.com
txt https://www.rfc-editor.org/rfc/rfc6570.txt
html https://www.rfc-editor.org/rfc/rfc6570.html
w/errata https://www.rfc-editor.org/rfc/inline-errata/rfc6570.html
bibtex https://datatracker.ietf.org/doc/rfc6570/bibtex/
Report a datatracker bug https://github.com/ietf-tools/datatracker/issues/new/choose

Viewport: width=device-width, initial-scale=1


URLs of crawlers that visited me.